The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Everything about using Libraries and Library Parts - Doors/Windows/Objects/Stairs etc. (Example: How can I display a Transom above my Door?)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy, Gergely Feher

#11360
In older versions (up to 6.5) of ArchiCAD, when I created a new object and saved in the correct library, the object was immediately loaded into the library. From 7.0 to now this object is added to the 'others' folder although it's saved into the library. This causes that different files of the same project load different libraries.

I need to manually delete the object from the 'others' folder to avoid the annoying re-load of the library (This is a problem when you have a Mac and the libraries are on a server: the process is sooooooo sloooooowwwww !) :cry:

Is there any way to alter this behaviour and return to the old way ?
#11410
Miquel Garcia wrote:In older versions (up to 6.5) of ArchiCAD, when I created a new object and saved in the correct library, the object was immediately loaded into the library. From 7.0 to now this object is added to the 'others' folder although it's saved into the library.
That hasn't been my experience. If I save an object into a folder that is loaded by library manager, it is immediately loaded ... and nothing about library manager changes. If instead I save it into a folder that isn't a loaded library folder, only then do I see the object under 'others' as an individually loaded object. Ideally, you should always save to a loaded library ... and the 'Save As' dialog has a convenient button that lets you choose which of them to use, saving time navigating to the proper folder.

HTH,
Karl
#11426
Miguel,

I think your problem is that ArchiCAD no longer defaults to saving the library part into one of the loaded libraries. Unless you specifically direct it to a library (there is a pop-up now to go straight to any loaded library) it will end up being loaded independently.