The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIMcloud/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIMcloud to make it accessible over the Internet?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, Istvan Moharos, Marton Kiss

#137784
We've got a teamwork file and have so far called up just over 50 details. For some really obscure reason some of the details (4 or 5, all from sections) keep crashing the program.

If I (as team leader with access to the details) or any team member clicks to open them in the 'Navigator - Project Map' it completely shuts down the program with a bug report appearing.

I've deleted the details and respecified them. Still having dramas.
10th crash in two days - very frustrating!
#137951
Try this troubleshooting steps:

1. Save your teamwork project as a local project. If it stops crashing, reshare it.
2. If it still crashing, save a backup copy and try to detect problematic elements in your model.
2.1. First, generate 3D, select all library parts, and delete them. Save this version and try to create problematic details. If you haven't any problem now, go back to the full version and try to detect problematic library part. If you suspect some library parts as unreliable, try to delete them. Especially if they are located in your detail section area. If you haven't any idea, go by half-by-half detection method. Select about half of Library Objects (it's easier to do on plans) and delete them. If ArchiCAD doesn't crash, then problematic elements were deleted. Undelete them and select half of them. Proceed with this scenario while you aren't detect problematic elements. It looks very time consuming, but half-by-half division method works well and doesn't take very long time really.
2.2. If problem doesn't related to Lib. parts, think about unusual walls intersections, other unusual elements and combinations. Test your project without this suspicious elements. If still no results, try to delete groups of objects type by type: all walls, all slabs, all roofs, etc. Save and test after each deletion. When you find out problematic type of objects, return to the first version of your project file (without deleted elements), recheck it behavior without objects of this problematic type. If all goes well, proceed with problematic library object detection scenario.
2.3. If you deleted all objects, but ArchiCAD still crashes, try to repair this file. Open new project with template settings (New and Reset). Delete all stories except one, all layers except ArchiCAD, open Attribute Manager, select all attributes and delete all which you can. After that merge your problematic project into this empty project. And test...

Good luck,
Leo
#137958
Cat_dunc,

first of all tell us more about the version (and build) of AC you are working on.
Secondly give us more info on the size, structure (modules, links, libraries etc) of project etc...
Thirdly try to find out what is similar in those 5 details and at the same time what is different to all non-crashing details.
#143477
We are having a similar issue with detail markers behaving unreliably in v12 (recent upgrade).
Large teamwork file (13 stories, detailed facade - inserted by hotlink, large site - inserted by hotlink with up to 6 members signed in simultaneously).
We have just moved into Construction docs and therefore setting up a large number of details, new layout sheets etc.

Two seperate team members are having trouble send/rec to the main file.
We diligently save PLC to local machines and they are able to recover the PLC post crash - however trying to send/rec just repeats the crash. One team member continued working in his plc and continues to receive notification of other team members signing in/out when he tries to send/rec, so he is still linked to the PLP on the server...He cannot receive changes either so we can't update his file and re-share that way.

Any suggestions on how to determine which detail marker is causing the crash? Does AC create a crash log which would tell us why the crash occured? (How easy would that make our lives??!) Currently looking at re-creating 3 days work in the main file if we cannot re-connect with the main file. Any suggestions appreciated.
#143480
sbrincat,

I'm not sure what will fix your problem I'm sorry.

Our problem however was fixed a couple months back. It was as simple as the libraries each computer was using. Some of the computers aren't connected to the internet, and I had forgotten to manually update their archicads. Once I had done that, then deleted and reconnected the library we never had the problem again.

I'm assuming it was a problem with one/several of the objects. A few of the computers mustnt have had that particular library connected with those objects, thus causing archicad to freak out and crash without warning.

Opening the floor plans and sections never caused a drama, though we got an object & library warning. Though opening a detail was a different matter. Seems they can't handle errors very well.

I hope it's as simple as that to fix your problem. Good luck!

cat
#143717
I hadn't even thought that the libraries might be causing the problem, since I (mistakenly) thought they were unrelated...but I guess nothing is truly unrelated is it?

As we have just updated from v11 we are still running 11 and 12 libraries from the server so it does make sense to me that this could be the problem.
Thanks for the tip.