The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIM Server/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIM server to make it accessible over the Internet?)

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

By Jody S Keppers
#158921
I recently installed R13 and the BIM server on my Dell Precision laptop. Teamwork worked wonderfully (just on my machine, no actual sharing involved, with ArchiCAD and the BIM server both on the same machine) until I shut down and restarted my computer. Now the following error pops up if I try to launch the BIM Control Center:

"BIM Control Center Error! Teamwork Monitor Service is not running! Please reinstall BIM server or restart your computer."

Trying to open a Teamwork project from within ArchiCAD, the BIM Server is listed as "offline."

I tried reinstalling the BIM server, but nothing changed.

Any thoughts?
User avatar
By LaszloNagy
#158965
If you go to the Task Manager (CTRL+ALT+DEL) do you see the three Teamwork Services listed in the Services Tab Page of the Dialog?
See attached image.
Attachments
TeamworkServerMonitorService.png
By Jody S Keppers
#158975
No. None of them are visible.

I've done some more work on this, and it seems to be a problem with my antivirus software (AVG Internet Security 9.0). When I disable AVG and restart, things work fine. Teamwork still works if I then restart AVG. But Teamwork will be broken again if I restart with AVG active.

I'm trying to figure out how to tell AVG that Teamwork is ok. I'll let you know if I figure it out. Feel free to tell me if you know the magic solution!

Thanks!
User avatar
By LaszloNagy
#158976
You are probably on the right track.
Anti virus softwares have done such things to AC before.
By Jody S Keppers
#158980
I have the solution. For others who have AVG and may run into the same problem, here it is:

Open the AVG User Interface

Open the Residential Shield Component control panel

Under "Residential Shield Settings" click "manage exceptions"

Set the "Residential Shield Directory Excludes" to include the BIM Server
folder (probably under Program Files\Graphisoft\Bim Server)

Click OK to accept changes.



BIM Server now works as it should after a restart.

I suppose there might be a way to eliminate the conflict without excluding the whole folder, but I had no success excluding only the BIM Server Manager.exe, BIM Server Control Center and TeamworkServerMonitorService.exe files.

I hope this helps others save some time!