The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Producing imagery with ARCHICAD or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

User avatar
By Rick Thompson
#231803
I am trying to do a quick rendering with trees using the internal engine. I can not get the trees to show up other than a black billboard. With Open GL they show up fine, but with a black line around the box. So, both are useless. Is there anything I am missing to make this work?
Attachments
Screen Shot 2014-08-08 at 4.21.40 PM.png
By Bricklyne Clarence
#232050
No problem on my end...

Internal Engine rendering...

Image

Also with OpenGL, as long as you remember to turn transparency on and turn contours off, you get a decent image as well.

What version of ArchiCAD are you using?
Because you mention in the post that you're using version 18 trees but your signature implies you're using ArchiCAD 17

I think the render engines in ArchiCAD 18 were re-configured to work with the billboard trees so that they're always facing the camera (if you refresh the view) regardless of what direction they were facing when you placed them.

I'm not sure version 17 had this feature and if not then it's likely you're trees are facing backwards (in the Internal Engine render) and giving you the black box.
(I'm not even sure the version 18 trees can work with ArchiCAD 17)

Or if you're in version 18*, you might want to refresh the view or re-load the view (close and re-open the 3D window at that view) to get the trees to face the camera again.

(if you're in version 18, why not use Cinerender? with one of the pre-loaded custom settings? It would be just as fast and much, much better quality)
User avatar
By Rick Thompson
#232051
Thanks for the feedback. Yes, I am on 18 and need to change my signature. I always forget:) I had a friend on 18 also try and he had the same results. The rotating is new to 18, but I don't know what I am doing other than logically placing them, but good to know you are having it work find. Are you on a PC. We are both on a Mac.
User avatar
By Karl Ottenstein
#232054
Rick, I just opened the default template for 18 and placed some elements and a tree. All is fine with OpenGL and Internal. (Have to turn contours off for OpenGL to not show the rectangle.)

See if that's the case for you... in which case you can then narrow down what's happening in your project, which I'm guessing was migrated and might not be using the same default surfaces as a fresh 18 project?
By Bricklyne Clarence
#232055
I'm on a PC, but I think I've figured out what your problem is.

Are you actually rendering the image (Documents>Creative Imaging>Photorender projection - from your menu) or just doing a screen capture ("Save as" from the 3D Window)?

Because everything you've described seems to indicate it's the latter.

You might want to actually hit the 'Render' button (PhotoRender Projection) to get the image you want otherwise turn off the Contours in the 3D Window Settings for OpenGL engine if you prefer to just to a 'Save As' option and don't want that border box to appear around the trees.

Unfortunately, it seems like Internal Engine can not handle opacity or alpha maps from the 3D Window (unless you actually render) so you can't get rid of the black box effect with it.
User avatar
By Rick Thompson
#232064
Bricklyne... yes, I think that is what is going on. I realized your rendering was a photo renderings. I actually like the Basic Internal engine rendering with lines.. I was after a better tree than the one where you set the leaf count etc. but maybe it doesn't display there. Hell, it would be fine but the black line around the box. I still hope I am missing a setting, or like Karl said, some migration issue. I will try it off the AC template and see what happens.

thanks to both of you
User avatar
By vistasp
#233072
Deciduous Trees 18 with CineRender

I don't know if this is expected behaviour or not but if we choose a ready scene (Outdoor Daylight Medium in this case) the alpha transparency seem to fail and a grey translucent rectangle betrays each billboard image.

Turning on Physical Renderer, however (next image) solves the problem.

Any reason why this is happening?
Attachments
test 01.jpg
User avatar
By Marton Kiss
#233352
vistasp wrote:With Physical Renderer turned on.
For scenes, where such objects are visible we strongly recommend to use the Physical Render engine. During the beta test of ArchiCAD 18 we tried to find a solution for this, but it is related to the C4D engine. We reported this to Maxon, so I hope in the long run they will be able to optimize the engine. Until then the best is using the Physical mode.

Marton