The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Hardware specific issues - computers, graphics cards, mice/input devices, system benchmarks, protection key issues, etc.

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

#257401
Hi all,

I'm having trouble with setting difficult to obtain when working in AC19 and AC20 on the Dell Precision M3800 with a resolution of 3840 x 2160 on the screen of 15.6 ",
In Windows 10 by default it will be shown on the Size Setting Zoom to 250% as a recommendation.
It looks good but on the field of ArchiCAD working font will look a bit blurry it will be different in some top titles and occupations are not the same look.

I tried in Zoom 200% of this decline will be seen perfectly smooth, together with all the fonts on the desktop field. But oh torture once the fonts will look quite small. It's uncomfortable to wear to work linger.

I compare at 3840 x 2160 resolution and zoom to 250% or 200%.
Performance for Panning, Zoom, smoothness of lines and 3D Orbit at 200% noticeably faster.

Surprisingly If the maximum setting held on Graphics Card if unloaded half or below the maximum resolution it will look a little slow decreased performance. At Dell M3800 that has Internal HD4600 and Quadro K1100M.

I hope that GS plans to repair this font adjustments when it is displayed on the screen is 3840 x 2160 UHD zoom 200% on a 15.6 "notebook displays.
At least the font may be enlarged slightly and adjust the same smoothness.

Enlargement of above 200% in Windows 10, such as 225%, 250% and 300% AC performance is noticeably slower.
I thought about how to restore my Dell with dismay at such high resolution? so painful to work and has run out of time just to find the right setting. Oh I thought it was good.
This turned out to meet a lot of important issues on UHD display in Windows. in this Retina MacbookPro appear so fantastic without worrying set the display again.
 
Is there in this forum experienced the same thing or have a trick for adjusting resolution and magnification Zoom more ideal in Windows 10 ?.
Thanks if anyone would like to share a solution.
#257403
I'm sorry, but there is no good solution in Windows 10. They changed the font rescaling between Win8 and Win10. I bought a 4K monitor myself, and ended up taking it back. Unless you operate at the native resolution (which makes everything small, of course), it will be blurry. see this thread: http://archicad-talk.graphisoft.com/vie ... hp?t=52968
#257601
Hi All,

The HDPI display handling of ARCHICAD 20 and previous versions are different on MAC and WIN. The Windows and Macintosh operating systems support HDPI displays on different ways.
On windows ARCHICAD uses the Win 32 API which gives only a basic HDPI development support, so development needs to occur to use HDPI. (On MAC this was a smaller effort.)

(Background info: Every application either does or does not specify how it runs on an HDPI display. The ones which do not specify DPI support are the 'Non DPI aware' applications. Without scaling, the HDPI display shows the windows of these applications extremely small because the pixel size is significantly smaller than on a normal display. To keep readability Windows scales up the UI of these applications: the window content is rendered by the application on a normal way and then Windows scales up the window image with a bitmap stretch. The scaling factor is dependent on the system settings. This scaling causes some blurriness, that is why the UI of ARCHICAD 20 looks blurry this way.)

The solution to this problem is that the scaling should be performed by the application itself and not by Windows. ARCHICAD needs to create bigger dialogs with bigger fonts and dialog elements.
This is an important priority for GRAPHISOFT and development has been initiated to support HDPI displays. It is planned for an upcoming version of ARCHICAD.

If you would like some more information, please read this article about how Win 32 works with HDPI displays:
https://msdn.microsoft.com/en-us/librar ... 85%29.aspx

To avoid blurriness, the scaling can be disabled in the application property dialog, but this causes everything to be very small.