The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Sharing a project for a team, accessing projects remotely. Setup of BIM Server/Users/Roles, Working/Messaging in Teamwork (Example: What are the firewall settings for the BIM server to make it accessible over the Internet?)

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

Since the release of 21 we have been receiving the attached message on multiple teamwork projects when attempting to send and recieve, for all users of the projects, sometimes multiple times a day. The message appears to be totally random, often a send and receive can be done without a problem.

We have tried the teamwork server installed on two different machines with the same result so are fairly confident it is not a specific hardware/software conflict.

We reported the issue before 12th July and as yet Graphisoft is not able to advise where they are with a fix but have informed us that this is actually a bug.

I was just interested to see if anyone else has had this problem, to try and establish if this is something related to our specific hardware/network environment. The result of this message means that any alterations or additions to the teamwork project are isolated from the teamwork project and bringing the information together means manually copying and pasting between two files (if you can remember all of the potentially hundreds of actions you've carried out). We estimate we have lost literal days of time so far in stitching back together fractured teamworks projects so are very keen to find a resolution.
Our workaround is this; set a timer so that everyone working on the project is reminded to send and receive every 30 minutes. So that when it does happen (and yesterday it happened 4 times between 8am and 10pm - it was a long day!) the amount of work that is disjointed from the main file is kept to a minimum.

I have to say, we are not at all impressed by the response from Graphisoft particular given the nature of the issue e.g. it is not a crash that we can use the recovery file for, it is not a 'nuisance', it is fundamentally causing us hours of lost time every day. Our office is also part of the beta program and identified the issue before the release version of AC21.
We are also seeing more of this detaching. It's not chronic yet, but it's more frequent than we've seen in a long time.

We just upgraded to AC21 last weekend, and can't go back (we eliminated the AC20 bimserver), so it may be too soon to tell.
We are still waiting on the fix, and we have sent them several Support Packages. They did tell us that the problem MAY come from a known workflow:

"We suspect that the following workflow causes the issue in Teamwork:
1. Create an element (e.g. a wall), and set a custom property to the element.
2. Use either the Drag a Copy or Mirror a Copy or Rotate a copy function.
3. Send the modifications.
4. Delete the previously created copied element.
5. Send the modifications. >>> Error"

It's also interesting to note that we've seen several error messages that mean the same thing. One even says something like "your file is ok, but we're not certain if it sync'd with the server, please try again", over and over.

There is a Preview version of a Hotfix Update, Build 4003/4004, available in the Graphisoft support site. However, we're very reticent to try a Preview. The phrase "Out of the frying pan, into the fire" comes to mind.
I can report this is happening to my office too for teamwork files. We are running AC21 5010 with BIM server 4003.

Agree that the error seems random. I've been lucky that when we receive the error, we just continue working for around 30 minutes and it seems to work fine again.
After installing Build 5010, I can say the problems have greatly diminished in our office. Still the occasional detachment, especially on older computers. but now it's rare.

A recent newsletter from recommended wiping out preferences and reinstalling ArchiCAD on machines that have been around for a few years. I think the support files on your machine can pick up old-age ailments.
Hello guys,

The problem is that this error can be caused by a lot of different issues. The original problem that Dan G is talking about was fixed in update 4022, and we have patched some other issues in 50xx as well (which is currently only available as a preview).

Since this error message is so diverse, all of these occurrences have to be investigated individually to see what causes the problems in each case. So, if you experience this problem, contact your local support team with a Support Package, so that they can check the logs and see what it might be.

Also, the problem that causes this might be fixed in your version already, but the source of the issue might still be stuck in the project, so it is worth eliminating that first:

1. Download and install the latest updates for both ARCHICAD and BIMcloud/BIM Server.
2. Download a PLN version of the project and Open it with Open & Repair
3. Re-share this repaired project, and see if the problem still persists.

I hope this helps!