The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Producing imagery with Archicad or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

#294985
Hi, I can't seem to get the 'Random Origin' surface option to work in the 3D Window. We use Maxwell and Lumion quite a lot for our output, and both take their texture coordinates from the 3D window, so the error is carried through.

These timber batons use a surface that has it ticked, but as you can see, the knot in the wood repeats on every baton, so we get these weird horizontal banding both in 3D window and Maxwell render.

It seems to work okay in CineRender - just not the basic engine.

Any ideas why it doesn't work?
Attachments
18124-Banding 3D Window.jpg
18124-Banding Maxwell.jpg
#294988
Seems like a bug, I can't get this to work either, however the help documentation suggests this how it should work.

Check and unchecking the option does nothing here.
#295743
Hello Everyone,

I looked into the investigation started by DerekJackson, and I thought I would post what I could see in case someone would run into this in the future.

So, it turns out this is a known issue (bug #103978). The Random Origin function doesn't work in the OpenGL Engine, but it does work for Rendering Engines (Basic and CineRender). We will look into this and see whether this can be fixed in the near future.

In this specific case though, the main issue is not with the OpenGL 3D View, but with the Maxwell add-on (If I understand it right). The state of the "Random Origin" toggle is actually available through the ARCHICAD API (Maxwell communicates with ARCHICAD through that), and the texture alignment should be done by Maxwell based on this information anyways (since it should manipulate textures anyways), so it might be worth contacting them with this issue, see if they can fix it on their side.

I hope this info helps.

Regards,