The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Producing imagery with Archicad or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

User avatar
By Scott Bulmer
#313554
Is Twinmotion Direct available for Archicad 24 and if so where is it? Thanks, Scott
By Sam Wheatley
#313579
Here is the response I received, just a few days ago:

I just got some more information from our person who is in contact with Epic Games. They let me know that we are waiting for Epic to update their plugin to include the latest version of Archicad. Sounds like we are expecting it in the next couple of weeks.

Hope this helps.
User avatar
By Rex Maximilian
#313696
Scott Bulmer wrote: Fri Jul 17, 2020 5:16 am Is Twinmotion Direct available for Archicad 24 and if so where is it? Thanks, Scott
It's not available yet. However, I would recommend not waiting for it and just proceed by saving out an FBX file from ArchiCAD (use the "Save As" Twinmotion) option from the 3D window. The previous direct links were very buggy at best and caused a lot of crashes.

Process:
1) Save out FBX file from ArchiCAD
2) Open new file in Twinmotion
3) Go to Import tab and bring in the FBX file
4) Save file as .tm file
5) Go back to ArchiCAD and make edits as usual
6) Resave FBX file replacing older version (of course use the same name)
7) In Twinmotion go to the import tab and select the FBX file that was originally imported and refresh
8 ) New ArchiCAD model will appear where old one was keeping all of the Twinmotion texture edits from before
9) This is basically a manual process of direct link, but without the crashes.
User avatar
By Scott Bulmer
#313789
That process works great, thank you so much Rex~! Regarding Direct Link, I too was experiencing quite a bit of bugginess but thought it was my system, thanks also for confirming that issue. Scott
User avatar
By mnguyen
#313990
Hi All,

Thank you for your questions!

Although I do not have any official information from Epic Games about when Direct Link addon will be available for Archicad 24, I hope it will happen in the coming weeks!

Regarding the issue with Direct Link's unreliability, sadly, this is not the first time I came across this issue. Although I never had it, I believe this is system-specific. Unfortunately, the addon is developed entirely by Epic Games, therefore we cannot tell exactly what caused those crashes and errors. I hope with time, they will be able to develop a much more stable version of it!

If you have any issue with Direct Link, I would highly recommend reaching out to Twinmotion's support, that can be found here: https://twinmotionhelp.epicgames.com/s/?language=en_US.

Let me know if you have any further concerns!

Best regards,
Minh
#314869
The TwinMotion direct link for AC 24 is available from Epic today:

https://www.unrealengine.com/en-US/twinmotion/plugins

EDIT: OK, so it says it installed, but in 24, it says to go back to the site to update the plug-in... Plugin in the 24 Add-Ons folder is dated July 8 after running this new installer. To be sure, I deleted that add-on and ran the plug-in update again... but got the same add-on (July 8 date) and the same warning on launching 24 that a new version of the 2020 direct link is available. Repeat forever... So, Epic either didn't really get this tested/working, or the error message is wrong...

It may be that the 2020.2 version of TwinMotion is required for the plug-in to work... that version is showing in the Epic Games Launcher. I have 2020.1.2 installed ... and it is so dumb that the TwinMotion app itself cannot notify us of updates. :-( Will try that.

In spite of the error message, the model IS sent to 2020.1.2...
User avatar
By Karl Ottenstein
#314879
So, after 7 hours to download over my slow internet (why does Epic make even UPDATES be 18 GB in size - have they never heard of patches? grr) - Having 2020.2 has no effect on the message displayed by the 'new' AC 24 plugin - it tells me to go update on every launch, from the page where I just downloaded the plugin. These guys. :-(
#314952
Carstenem wrote: Tue Aug 11, 2020 1:55 am Thanks for the heads up saves me testing it out !
To clarify: it does seem to work for both 2020.1 and 2020.2 ... the issue is it displays a warning to update the plug-in every time AC is launched. Hopefully the update check error is the only bug / issue - so please DO test as you have some real models that could stress test it. :-)