The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, Gordana Radonic, nbalogh, mnguyen, gkmethy

By toman311
I’m not able to save my ArchiCAD file and I don’t know why. I tried saving the file to a different folder and even changed the name and it wouldn’t save. I keep getting a pop-up box saying, “Cannot save Plan file.”

I’m not sure if it’s related to another person at the office opening the project file as read only. The last project I was working on, he opened the same project as a read only and it created the problem where I couldn’t save too. Still, I was able to save later on. I deleted the lock file and it allows me to save.

With this new project, I deleted the lock file and I still couldn’t save. I also moved the lock file to another folder and that still wouldn’t allow me to save.

I am able to work in another project and save that one, yet I still can't save in the one that I've been trying and asking for help for.
User avatar
By Karl Ottenstein
It sounds like a MacOS permissions problem. Are you at least able to Save As to your own Desktop or Documents folder? If so, then some of us can help you track down the permissions issue with the original file and file location.

PS. Is your signature up to date? You're still on Mojave? And the issue is with 23?
By toman311
You're right about my signature being out of date. Sorry.
I am working in Catalina, not Mojave. The issue is in ArchiCAD 23 though.

Still, though, I can't save to my desktop or to the server. I'm not able to save anywhere that I've tried and I'm not sure where else to try.

I have sent this into Tech Support also, but I thought it would be a good idea to post this issue here too.
User avatar
By Karl Ottenstein
Thanks for posting the additional info. This seems really strange if you can't save to any location, which would include those that you certainly have write permission for. Almost seems like a license issue then... glad you contacted support. Please post back here once they diagnose the issue so that others can read the solution. :-)
By toman311
So Graphisoft support said check to see if ArchiCAD needs to be updated.
I did and it was out of date, so I updated ArchiCAD.
Sadly I had to close out of the file I couldn't save to update ArchiCAD.
Luckily I didn't do much work on it, so it wasn't that big of a deal.
So, after telling everybody in the office what happened, they updated.

Then another employee started to have a similar problem, except that no one was trying to use the file but him. I asked him to check and see if his ArchiCAD wasn't updated. It wasn't, so he had to close out of the file he couldn't save and update. Again, luckily he didn't do much work on the project, so it wasn't that big of a deal. AGAIN.

I'm scared to work with an out of date ArchiCAD now. I wish Graphisoft would send us e-mails telling us when a new update is release. If they do, I haven't been receiving them as far as I know.

I don't remember having this problem before. Seems to be only on ArchiCAD 23, but that's the only version I use at the moment.
By toman311
So it looks like I'm having the problem again and I'm all up to date on ArchiCAD 23.
I can save down to ArchiCAD 22 and I can save an ArchiCAD Archive file, but I can't "Save" or "Save As" on my computer desktop or on the company server. I get the error message, "Warning! Cannot save Plan file." The only option I get to respond to this message is "OK". I spent a lot of time adjusting this project's model and construction drawings and I really don't want to lose any of it.

The title of the file at the top of the ArchiCAD window now says, "Project Name.pln [Read-only]".
It shouldn't say read-only because I have been the only person working on this drawing (at least that I know of). I had the rights to make and save changes to the drawing when I first opened it. I don't know why it is now saying read-only.

I'm not sure what to do about this. This is the first time this has happened when ArchiCAD is fully updated.
I wonder what Graphisoft is going to say to this because ArchiCAD is fully updated.

I'm sick of this problem.
User avatar
By sboydturner
Are you using cloud synced folders / files using Dropbox , OneDrive etc? If so that is what is causing your problem.
User avatar
By mikas
Are you using cloud synced folders / files using Dropbox , OneDrive etc? If so that is what is causing your problem.
I don't mean to be personal, but in my opinion that really is too harsh of a conclusion.
At least with DropBox, using it exlusively for years allready.

And to me it seems the OP is working from/to company file server, though it's not mentioned what kind of a server and software is in use.

That's why I think it might be Catalina, server software and/or AC23 mix related problem. I am sticking with Mojave myself, I don't think Catalina is the most robust OS version released by Apple. Graphisoft too recommends Mojave, not Catalina (

About DropBox "unable to save" problem:
You might get the problem of "not able to save the file" with DropBox sometimes, quite rarely I'd say, and the problem will be temporary only. It will start working after a while by doing nothing. I believe this temporary glitch depends on file size and your disk speed and/or internet speed might be a factor too. And you allways will have the opprtunity to "Save As" thne you face this problem.
I don't think document has never converted to "Read Only" for me when this appears.

And never have we lost anything because of this. Quite the opposite, I have been able to save files from DropBox after someone has somehow managed to delete some essential documents.

I am not going to say cloud is the future, because the cloud is there allready and every day. I'd want graphisoft to embrace cloud storage. To work with major cloud services to make ArchiCAD compatible rather than just say "we do not support working from cloud storage". So Please support it Graphisoft. At least please make sure you do not make cloud storage incompatible with your products. (DropBox, OneDrive, iCloud, Google Drive and a variety of Amazon services etc.). Thank You.
By toman311
Graphisoft Tech. Support got back to me and said this,

"Sorry to hear about this problem.
This error usually happens when saving to a file server or cloud-synced folder (i.e. Dropbox) because these solutions read and write to the file and cause corruption. Please make sure that wherever you saved is a location that is not actively monitored, running in backup, or part of a synced solution (most solutions will be easy to spot from the sync/green checkmark icons next to each folder and filename.
If you are running some sort of anti-virus and anti-malware application, these might also be monitoring and opening files, blacklisting files. In this case try turnign it off.
Let me know if you have any questions or if it still doesn't work. If you were able to save an Archive file after a while, at least that can save your work from being lost."

I've sent my message below back to Tech. Support...

We’re not backing up to a cloud service. We have a local backup server that isn’t related to any cloud service that isn’t even attached to the internet. Even if that could still be causing problems, we’ve been backing up to a local server for many years and haven’t had any problems till the late 2020. That’s when this save problem came up. The server does back up to another server through the internet that is at the firm owner's house, but it’s been that way for a 3 or 4 years now and we’ve never had problems before. The office server backs up once at night, so I don’t see how that could be a problem related to this saving issue.
Even if I try to save to my desktop completely separate from the server, the file still won’t save. I tried giving a separate name but the file wouldn’t save. The name of the un-savable file would change though to what I typed in.
We do have an external hard drive that backs up our Mac’s through the Time Machine app. We’ve been using those for a couple years now and we haven’t had any issues with saving files before.

This is a big issue though to us. This is the fourth time this has happened in our office in the past 2 or so months. This is the second time I’ve had this happen on the current project I’m working on and I’ve had the problem on another project. Someone else in the office has had this problem once too, so it ain’t just me. Two of the times this problem happened to me was when someone else opened up a read-only file of the project I had open with full rights to save.

We are all running on Catalina, but we did that update a little while ago that didn’t cause any problems that we’ve noticed after the install. I don’t remember exactly when we updated to Catalina, but it didn’t cause any problems close enough to the update that I can make a connection that Catalina is the problem. Plus, the 3rd person in the office isn’t having any problems with this. All three of us are on Catalina, we all save to the server, and we all have Time Machine running. So I’m not to sure how to make a connection to figure out the problem.

I’ve contacted Tech. Support before and they said to just make sure ArchiCAD is up-to-date. The first three times we had this problem, our ArchiCAD has been out-of-date. This is the first time it has happened when ArchiCAD has been up-to-date. This is a reoccurring problem that we wish could somehow stop. I'm not sure what to do about this either.
By toman311
Graphisoft asked me to create a Support Package with Logs taken right after the problem happens.