The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding Archicad (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an Archicad error please always report it to your local reseller!

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, Gordana Radonic, nbalogh, gkmethy, mnguyen

#233617
i was contacted by graphisoft to try a couple things, im guessing the rest of you were as well. I tried what was suggested with editing the ipcconnection in the registry editor. i set the disable to 1 instead of 0. i can now open multiple ac windows with no issues. i can also still copy and past from one to another.
By GeNOS
#233672
i havnt had a chance to try this yet.. im not to "computer smarts" so iv been avoiding it in case i stuff something up.


i wonder why this issue is happening for some and not all?
By GeNOS
#233713
SenecaDesignLLC wrote:i was contacted by graphisoft to try a couple things, im guessing the rest of you were as well. I tried what was suggested with editing the ipcconnection in the registry editor. i set the disable to 1 instead of 0. i can now open multiple ac windows with no issues. i can also still copy and past from one to another.
i just did this to mine also, and seems to have fixed the problem :D
#233733
GeNOS wrote:i wonder why this issue is happening for some and not all?
In my case the problem seems to be insufficient memory. While the 4GB RAM that I have is the minimum required to run ArchiCAD, Csaba Kézér at Graphisoft Technical Support advised me that you really need 4GB for each instance of ArchiCAD in order for both to run safely and quickly. Disabling the IPconnection in the registry didn't work for me: a second instance of ArchiCAD refused to even open. I'll try that again, however. User Error is always a strong possibility with me.

Truth be told, I've gotten used to closing one project and opening another to get things done: Turns out its a lot faster than waiting for that second instance to boot up.
#233746
Hey All,

We have been investigating this issue with the help of some of you. What we managed to find out from the logs you sent to us is the following:
- The issue is that the two ArchiCAD instances cannot connect to each other properly. We couldn't find out just yet why does this happen in some cases, so the source of this issue is still under investigation.
- The memory being used up is the consequence of this bad connection between the two ArchiCAD instances. We will address this by not allowing the high memory usage even if the communication between the two instances is not working fine.

At this point I would like to emphasise that disabling the IPC connection in the registry is not a solution to this, it is only a workaround. Disabling the communication works the following way:
On Windows
In the Registry Editor set the Disable key to 1 in HKEY_CURRENT_USER\Software\Graphisoft\ArchiCAD-64\ArchiCAD-64 <your AC version>\IPCConnection\
https://drive.google.com/file/d/0By86zx ... sp=sharing

On OS X
In the ArchiCAD preferences file /Users/username/Library/Preferences/com.graphisoft.AC-64 <your AC version>.plist under IPCConnection set the Disable Boolean key to True
https://drive.google.com/file/d/0By86zx ... sp=sharing

More about Registry Editor or Preferences: http://helpcenter.graphisoft.com/?p=25471

With this switch being disabled the following functionality is not working:
1. Views placed from external files cannot be updated and checked.
2. Selected layouts or drawings on a layout cannot be merged from the Navigator/Organizer. It only works for the entire Layout Book with the Merge command.
3. Open source view command is not working for drawings which are placed from and external view.

To resolve the issue try to delete the IPC Data folder on your machine:
Windows: C:\Users\username\Graphisoft\IPC Data
OS X: /Users/username/Library/Application Support/Graphisoft/IPC Data

Best regards,
Csaba