The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Producing imagery with ARCHICAD or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

By Mo Muk
#255551
hi everyone!

i'm trying to load an Image texture to render a tiled floor. (see attachments) the tiles should have brownish colours but when i use the cinerender to render it changes to greenish gray? in the internal renderer the colours are fine so the Image is correctly loaded.

any ideas on how to preserve the image's natural colours during Rendering?

thanks
Attachments
Unbenannt.PNG
the original tile is on the left
User avatar
By Erwin Edel
#255555
The colour changes, because it is hit by light, which in turn has a colour. It can also be reflecting some of the surroundings, etc etc.

You can try changing the colour of sun / other light sources to close to white, but if you are aiming for photo-realism, this might not be what you want.

Floors especially are affected by light, as they catch a lot of it. The same material on a wall, ceiling or floor, will look different, due to the amount of light that is hitting it.

Also take a look at the reflective settings of the surface in the cinerender settings.

Read up on all the surface channels, to see how they react to light etc http://helpcenter.graphisoft.com/guides ... -channels/ to make a better attempt at solving the change in colour.
By Mo Muk
#255566
hmm i've worked my way through all the Settings and cahnged the sunlight and Skylight Colors to White. but as you can see the Colors are wrong in the Settings window . that is before it is even rendered :/
By alemanda
#255567
sometime the default windows photo viewer applies a different color profile to the picture ... especially jpgs
User avatar
By Erwin Edel
#255570
Internal engine uses the internal sun settings (see below), cinerender does not use that.

As you can see, I've set the sunlight and ambient light to pure white there as I got 'tired' of having to adjust for the colouring in openGL view/internal engine.

Cinerender is a very advanced renderer, which sometimes, unfortunately, means there are a lot of settings to adjust.

Maybe start by ticking off settings in the detailed settings to see what is affecting the colour the most.
Attachments
sun.jpg
User avatar
By arqrivas
#255577
Hi, If you can't get the right color with the light settings, here is another way to get the right color you want, by using the filter in the color channel of the surface.
Besides this have in mind that the diffuse color can also change the final appearance of the surface, and also the specular color.

http://screencast-o-matic.com/watch/cDhFI3ic76
User avatar
By arqrivas
#255578
Additionally to what I just told you, you can also play around with the mix mode in the color channel, using the multiply, add or substract mode (each one will give you different results), this way you can "tint" the final color of the surface.
Attachments
mix.JPG
By coxy761
#283757
Hi, in case you haven't found a solution, you need to add the texture to the cinerender settings

go to options - element attributes - surfaces.
find the surface that you want to edit and go to engine settings, choose cinerender.

check the color tab, then expand it , click image , in the settings page on the right choose filename, browse for the same texture u want to use and apply it there, you can play around with the other settings..

hope this helps..

PS. Im still trying to prevent my textures from tiling, if anyone has any ideas they are welcome
Attachments
hallway.jpg
User avatar
By Lingwisyer
#283782
Im still trying to prevent my textures from tiling, if anyone has any ideas they are welcome

You can change the physical size of the texture in the first tab in the CineRender settings, or next to the image in the Internal Settings. You will need to set it to be equal or larger than the surface you are applying the texture too. In that way it will not tile. The down side of this is the required resolution of the textures you use. An alternative is using a seamless texture as this will this will allow tiling without the harsh joints you are getting. With a bit of duplicating, blending and recropping, you can make a "seamless" texture in Photoshop from most unidirectional textures.



Ling.


ps. Coxy's post, and this reply, should be split from this thread as they are not relevant to the OP.