The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!). <br />Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!<br />

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By Kassandra
So yesterday a problem occurred, a third of the window where the drawings are are just white (see screen shot). It occurs on both old files and new files. It is possible to scroll but the white area stay. Pretty soon after opening the file not only the program freezes, but the whole computer becomes unresponsive.

When I used archicad last weekend it worked fine. Anyone know what to do? Should I reinstall it or install archicad 20?
Skärmavbild 2017-02-01 kl. 10.25.26.png
User avatar
By Erwin Edel
Check that your OS and ArchiCAD are up to date, this looks like a problem with the GPU.

If everything is up to date, see if you can run hardware test on your mac to check if nothing is wrong with the GPU itself. Reboot and hold down D should do that, I think.
By Kassandra
Thank you, I thought it looked like something GPU-related. However everything is updated and did hardware test showed nothing wrong. I'm going to try running Archicad 20 and see if its a similar issue there.
I had a similar problem on a PC but it was the 3D window that went white (sometimes black).
The model was still there - you just couldn't se it but could select it.

I am not sure if it is related but this PC had a GeForce graphics card and was running a program called "GeForce Experience".
I deleted that program and all was fine again.

By Kassandra
It seems to be a problem with the driver included in a new update of mac os as written about here: ... -4-update/

This solved it for me, at least for now:
3. Crash

If the ARCHICAD crashes during the startup process and users can’t accomplish the above mentioned workarounds, the Antialiasing must be turned off manually by changing the following registry key:

~/Library/Preferences/com.graphisoft.AC-<ArchiCAD version>.plist
Open it in Pref Setter or Xcode
Select OpenGL (integer) folder
Select the key called Antialiasing Mode.
Change this key to -1
Press cmd+S to save or Cmd+Q to leave the dialog and save the changes.