The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!). <br />Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!<br />

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

User avatar
By daninet
#271064
Hey All,

There was a similar topic, but it was dated back when 20 was not out yet.

I want to tell how disappointed I am with the scalability of the new interface.
I'm not talking about the icons, I'm talking about everything else around it. Seems like there were no efforts in setting it up for modern screens other than changing the icon set.

With the 4k displays everyone is using some sort of DPI scale as things can get really small. Even with 1080p resolution people tend to use 125% scale then use the DPI fix utility under windows 10 to avoid blurry lines.
But Creators Update is here, we have a lot of new feature!

I think it is not a new phenomenon that windows notebooks are also getting 4k display not just macbooks.
The downside is you have to use 200-300% scale in the system and this is handled by archicad pretty bad. VERY BAD!

There is 3 option to choose but two is the same:
1. Blurry text interface with super tiny mouse (System default)
2. Glitchy interface with super small element (Application)
3. Proper interface with screwed up working area (System enhanced)

Do anyone have a working setting/solution on this?
Why we can't have manually scalable interface like Adobe products?
Why the work area not scaling with the rest of the screen?

It is a pain to use it like this without external screen. Or I can't see the mouse, or the interface falls apart.
My only solution to use archicad right now is set the resolution to 1920x1080, change the dpi scale settings, log out, log in, use archicad, then put everything back as not native resolution looks like crap.
Unacceptable!

Screen shots are on below links as forum supports only up-to 1600px. Check it with fit-to screen on a notebook to see what I can see.

20 and 21 are the same.

https://drive.google.com/drive/folders/0B1SVuqYkkUVbWlFJdWo2RXhjWWs?usp=sharing
#271075
This is an operating system problem, no issues on MacOS but problematic on Windows 10
User avatar
By daninet
#271077
I don't agree. Autodesk and all Adobe software is OK. Adobe all separately scalable, I can have different UI scale then the system!
There is problem with other software but non of them have updated UI.

Yes, Win10 has changed but change did not happen lately. It was there before they have started the AC20 UI upgrade.

Let's say it is some stupidity with the OS. Windows is Archicad's most popular platform, ignoring this is a huge mistake.
User avatar
By sboydturner
#271079
I wouldn't say Autodesk software all ok AutoCAD interface elements sizes are all over the place on my screen, cannot read many dialogs / pallets as text too large to fit within area defined for element whilst others are tiny (ACAD 2018).

Scaling of applications and interface elements should be handled by the OS not by application directly, macOS can use vector graphics for icons dialogs etc which is why scaling for different UI scales is handled well (ArchCAD for MacOS uses svg elements which is why there are no issues on Mac). What resolutions should icon and dialog sets be created for? (My laptop 286ppi, desktop 185ppi, home desktop 96ppi) Maybe 96ppi, 110ppi, 137ppi, 163ppi, 185ppi, 205ppi, 286ppi to cover the most popular monitor sizes today - just seems like a huge waste of resources (time & disc space) plus increased risk of QA issues for something that should be done by the OS

Scott
User avatar
By daninet
#271086
Problem is not with icons. I know AC20 renders the icon at the opening of the software under windows so it is sharp. It doesn't even need huge amount of resource.

Problem is that interface falls apart when you scale DPI settings (or you can go with small mouse+blurry font). This is something common anyone can do. Windows allows you to scale from 0-500% and this range should be covered.
User avatar
By dkovacs
#272266
Hello daninet,

Out of the 3 options you mention in your original post, the first one is the one we suggest/support (the other two are not recommended). It indeed makes the whole interface look a little blurry, but that's the nature of the upscaling of non-4K-compliant applications.

This is of course just a temporary measure not a final solution, until we introduce full High Resolution support to the Windows version as well. Unfortunately, it is much harder to make that happen on Windows than it is on macOS (nevertheless, we are working on it).

You also mention that in this mode the cursor is unnaturally small. This is because of an issue that surfaced with the Creator's Update. There's a thread about this small cursor issue, you can find out more about it, along with the solution there:

http://archicad-talk.graphisoft.com/viewtopic.php?p=272263

I hope that you can resolve the small cursor issue, and keep working on!
User avatar
By subatomic
#279040
Unfortunately we have an addition problem on Windows machines when scaling to 125% - text blocks are displayed off-center when formatted to anything other than left align. This is a display problem in Archicad 21, printing and PDFs are correct however.

It does not occur in previous versions of Archicad nor is it limited to 4k displays. Also Macs are not affected.
Setting the scale to 100% or 150% does not invoke this either.

Archicad 21 on Windows with screen scaling set to 125% displays text off-centered relative to the the text box when the text is set to right or center aligned.

I will be submitting a bug report but I am just wondering why no one else has discovered this. We've only been working on 21 for a few months.
Attachments
XO.png
XO.png (28.64 KiB) Viewed 606 times
User avatar
By dkovacs
#279106
Dear subatomic,

You don't need to submit this bug report, we already know about this. It has been reported on several channels, including ARCHICAD-Talk:
viewtopic.php?p=273155

It is caused by a development towards 4K (HDPI) support. Implementing full HDPI support for the Windows version should solve this problem for good (hopefully in the next main version).

Until then (as you've mentioned), using a different scale can solve the issue. Also note that this should only be an on-screen display glitch, published drawings should display properly.

Regards,
By bgoodale
#279884
so that's the issue with the text! i've been looking for a solution, and there it is! :D