The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!). <br />Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!<br />

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy

By luisdias
#275108
This has been a recurrent problem since shadows have become a staple in the OpenGL window, and no one has ever explained to me why this is an issue.

Whenever I open the 3D window it's a bit of rolling the dice. If I open it with a marquee or not, there's a chance that the shadows become completely chaotic. If I change the marquee (or not use it at all), the situation changes and the shadows are presented correctly.

I haven't found a logic to this at all. Sometimes it works well when I use the marquee, sometimes it [i]stops [/i] working well when I use it. Sometimes, it's how you draw the marquee. It cannot be an object, since many times it's only when I use the marquee that the problem occurs (and I'm not cutting objects in half when I do that, for instance).

I'd love to finally get some kind of feedback on this issue.

Note - the attached image shows chaotic shadows, but I just have to change the marquee a tad bit (or show the entire project in 3D) and the shadows are totally fine).
Attachments
House_badshadows 20171206.jpg
Chaotic shadows!
User avatar
By dkovacs
#276503
Hello Luís Dias,

I have seen such an issue before. It is caused by some clash between ARCHICAD's OpenGL Engine and the video card. It doesn't mean that it is incompatible, there's just something about that specific video card (or driver) that doesn't work quite well with this component in case of high polygon count. Of course there's probably some specific calculation that the card can't handle, but from a user point of view it seems random. The development team is looking into whether there's a solution for this, but it will take time.

Most of the time these projects should look fine on other computers (with other video cards). If you happen to experience this on other computers as well, it might be something new, in that case you should contact your local support team.
It is worth checking if you have the latest GPU driver, and if you have enough RAM/VRAM. Also, changing the View (eg. turn off marquee cut as you have suggested), and/or using Rebuild & Regenerate (ctrl+alt+shift+R) might resolve the issue. Additionally, since this tends to happen to projects with a High Polygon count, you might also want to try lower the number of polygons in your View (eg. turn off layers of overly-detailed interior furnitures).
Since this problem is limited to OpenGL, Renders and Views in vectorial Engine should look just fine, so make your final pictures/drawings with those.

Good Luck,
By luisdias
#278277
Regarding the video card, I've been using a PC with a GeForce GTX 1060 with 6 GB of RAM. It's not exactly a thousand dollar graphics card, but it's not half bad either, and it's not old. We keep drivers up to date almost at the day of their releases.

Additionally, this was also a problem with my previous graphic card, and my colleagues also have older different graphic cards (RADEON HD 7800, etc.), with the same phenomenon. This has been the case for several archicad releases so far.

We haven't been using 3d window as a presentation tool, but rather as a working tool. It's very useful to see how shadows work in our projects, and since version 21, it's really good to see them in real time.
User avatar
By dkovacs
#279110
Hello Luís Dias,

Well, if you say that this happens on other computers as well with the same file, then this could be something different from the problem I was talking about (and yeah, that's a pretty decent card :D). If you could send me the file in a PM, so that I could try to reproduce it here in our office, that would be great!

Thanks, Daniel