The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy, Tibor Lorántfy, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik

Hi !
I've recently been facing a strange problem I haven't been able to resolve: for some reason, any task related to image-printing (such as using ACAPI_CreateElement for an image) ends up working in my development environment, but completely crashing ArchiCAD on a user environment.

I tried statically and dynamically linking the libpng, fiddling with my compilation options, sending both a Debug and Release version to test, but nothing worked : It would always end with ArchiCAD crashing, and an empty error log.

Do you have an idea of what is causing it / the steps I can take to find the root of the problem ?
Thanks !
Hi again, sorry for the long hiatus, but I am currently working on-site until the end of the week, so I'll be able to get the much needed data for debugging this !

I got a .rep bug report and could find some logs in /users/USERNAME/Library/Logs/Graphisoft, but none of the files I found were human readable.

The files are zipped available here :

On a side note, it just recently started having the same problems with a dockable palette. Do you have any best practices on how to troubleshoot problems happening exclusively outside of the development environment ?

Thanks !

The error log you sent shows a crash in DGModelessClose().
(hint: you can open the .rpt file in any text editor)

If ACAPI_Element_Create just crashes at the user's site, then please try to obtain a bug ID, or the Apple crash logs from the user.

Maybe your Idee2Plan.bundle doesn't clean up its palette correctly (please don't use modeless dialogs, just palettes or modal dialogs).

Best, Akos