The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy, Tibor Lorántfy, rmasaki, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik

#298114
As the title suggests, I have duplicate entries of the same Add-On, only from different locations. I suspect I understand why since one is from the default local install location and one is from my network location.

It appears that once an Add-on is loaded, it stays loaded. My 'designated Add-Ons folder' is at a network location. However, I cannot remove the duplicate entries [from the default local install location] now that they are no longer wanted. I highlight the add-on that comes from the local location, yet the 'Remove' button does not activate in the 'EDIT LIST OF AVAILABLE ADD-ONS' panel. When I highlight the local version of the Add-On in AVAILABLE ADD-ONS, 'ADD-ON INFO' tells me 'The Add-On is already loaded.'. And it is, from the network location.

I have also removed the local Add-Ons folder from the ArchiCAD 22 tree, thinking that "An Add-On cannot be removed from the list if it is in the designated Add-Ons folder" was preventing removal, even though my pointer is currently set to a network location. No help there.

I also unchecked 'Use designated Add-Ons folder'. No help there.

Anyone have better ideas than mine?

Thanks,
- chris
Attachments
Add-On double entry.PNG
#298357
Hi Chris,

You'll have to use regedit.exe in this case; please go to Computer\HKEY_CURRENT_USER\Software\GRAPHISOFT\ARCHICAD-64\ARCHICAD-64 22.0.0 INT R1\Add-On Manager, and set the 'Default Location' to '%DEFAULT%', and the 'Use Default Location' to 1.

Sorry, Akos
#298380
Unfortunately, editing the registry setting for 'Default Location' to '%DEFAULT%' switched my pointer for 'designated Add-Ons folder' from the desired network location to the original C:\ drive location of the ArchiCAD install. Sorry if I was not clear that I wanted to keep the duplicates at my network location. Or perhaps some other setting caused the switch back to my local HDD. I used the 'Change' button to edit that pointer back to my desired network location. I then removed the directory tree from underneath C:\Program Files\GRAPHISOFT\ARCHICAD 22\Add-Ons by placing it on my Desktop. This removed the unwanted duplicates from the known ArchiCAD environment. Restarted ArchiCAD.

Prior to this move, clicking the duplicates gave a message 'The Add-On is already loaded.' After moving these to my Desktop, the duplicates were still in the list of 'AVAILABLE ADD-ONS' and still gave a message 'The Add-On is already loaded.' But now clicking the yellow triangle with the ! would switch it to an empty checkbox and activate the 'Remove' button. And clicking the 'Remove' button did get the undesired duplicates off the list.

Thanks for the reply and making me look at this again.
- chris