The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Speed/Display issues/unfamiliar error messages, crashes/hangs or any other problems regarding ARCHICAD (Example: I get an error message when the 3D Window is generated, please help!).
Note: If your problem seems to be an ARCHICAD error please always report it to your local reseller!

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy


About 2/3rds of the time when I use the Explore Model-mode (little walking man icon) to walk and look around in my model (it's great for aligning views to match with photographs) the view drifts on its own in one direction, as if I'm continually press a button. It occurs in different directions at different times, and I've tried with another keyboard to rule out some keys sticking or something like that.

The only way I can resolve it is to completely restart ArchiCAD but even then it's a gamble since it occurs so frequently.

I'm using 2 monitors with ArchiCAD only on one of them, and unplugging one does not seem to solve it, and an Nvidia GTX 1060 GPU, with the latest drivers installed.

Anyone else having these issues?
I found one similar post - there may be others if you do some more searching.

viewtopic.php?f=20&t=54593&p=262432&hil ... ve#p262432

It seems the solution was not unplugging the monitor, but moving Archicad tom the other monitor.
Maybe you could also try running Archicad NOT maximised to the screen, but manually resize the program window.
No idea if that will help or not.

Christophe Fortineau wrote:
Fri Jun 14, 2019 11:13 am
Did you try to reproduce this case with the standard AC work environment? Would you have set keyboard shortcuts that would cause dysfunction
That's a good idea, and I tried working with the standard environment for a while but the bug still appared.

I'll try to move the whole program to the second monitor if it happens again.
Barry Kelly wrote:
Mon Jun 17, 2019 2:49 am
It seems the solution was not unplugging the monitor, but moving Archicad tom the other monitor.
Maybe you could also try running Archicad NOT maximised to the screen, but manually resize the program window.
No idea if that will help or not.
Just tried this, didn't work. No matter which screen, if they're both turned on or off, maximized or not, it drifts. And I had this problem on a previous computer as well with another graphic card, but was hoping it would be solved with a newer computer and GPU, but still persists. I've tried to search but have not found anything else than the thread you linked and another older one with nothing helpful in it.
All work files, but not all the time, I'd say around 75% of the time though. Sometimes it has stopped after a while if I press left-right-up-down etc over and over, but most of the time I have to restart ArchiCAD to fix it.

In my experience, the following things are known to cause creeping. Might be worth checking them all out:
  • The culprit in most situations is the keyboard or the mouse, and/or their drivers. I have seen an issue where buttons got stuck on the keyboard. I have also seen an issue where this was happening with every keyboard and mouse, but turned out that the default touch pad driver was faulty, and it caused this issue regardless of what mouse you connected. So definitely try removing all keyboard/mouse drivers, and then attach a different set of keyboard+mouse to the computer to give it a go with those (different make and model than what you usually use).
  • I have seen one case where a similar issue was actually caused by a third party add-on that was installed. If you have any Add-ons installed for ARCHICAD, try removing those to see if that helps.
  • The video card, the screen and their drivers can cause all kinds of crazy symptoms, but I never actually heard them causing this before...
If the same thing happens with your projects on other machines, then there must be something about your projects that cause this. Maybe you are working far from the ARCHICAD origin? If it works fine on other computers, then there is definitely something up with the machine itself. Most of the time it is hardware/driver related (as I have mentioned before), but if you haven't done it in some years, maybe if you reinstall the OS to start a clean slate, the problem could go away?

I hope some of this can lead you to the answer. Please, let us know if you have found the solution.

I have tried to diagnose further with removing keyboard and mouse but it is tough to test because the problem is not consistent, and might mean spending days working with other equipment and still not confirming much. Will try to continue to find out the reason of the issue, but until a coworker of mine had the same problem and he would solve it by quickly pressing the button of whatever the direction it was creeping. So if it drifts to the right press D and it usually solves it.

I had tried this as well without success but had disregarded one important fact: there are two keys for each action. I had been using WASD and pgup/pgdw to move, but he was using arrow keys and C/Space, and if pressing one set doesn't solve it usually the other set does.

By the way we are using similar hardware, software and projects since we're in the same office so might still be caused by something local on our end.