The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Discussions about using GRAPHISOFT's tools (API DevKit) for independent software developers

Moderators: Karl Ottenstein, LaszloNagy, ejrolon, Barry Kelly, gkmethy, MOREH Tamas, Akos Somorjai, Ed Brown, Mihály Palenik, Tibor Lorántfy, rmasaki

#303209
Hi,
When I edit the .grc file,e.g
character1.png
I compile the code. the error occur,
character2.png
character2.png (3.91 KiB) Viewed 205 times
character3.png
But I set the less characters, these is not error.
character4.png
I want to know whether there is the limit of chinese characters in grc file.

thanks.
#303237
Hi akomporday ,
The relevant code :
Code: Select all
'GDLG'  ID_DIALOG_FILE_RENAME  Modal | noGrow    100   100  720  734  "文件命名配置" {
/* [  1] */ Button				  554   694   78   30	LargePlain  "保存"
/* [  2] */ Button				  642   694   78   30	LargePlain  "取消"
/* [  3] */ Button				  466   694   78   30	LargePlain  "应用"
/* [  4] */ TextEdit				15   42   400   30	LargePlain  100                   
/* [  5] */ CheckBox				15   99  200   30	LargePlain	"启用字符分隔符"
/* [  6] */ PopupControl		    15    163  150   30	 80  3						
/* [  7] */ PopupControl		    185    163  150   30	 80  3						
/* [  8] */ LeftText			  15   20   84   20	LargePlain  "总文件平面名称"
/* [  9] */ LeftText			  15   141   60   20	LargePlain  "字符分隔符"                  
/* [  10] */ LeftText			  185   141   72   20	LargePlain  "建筑编号排序"
}
Thanks.
#303894
Tibor Lorántfy wrote:
Fri Nov 08, 2019 3:22 pm
We were not able to reproduce your issue. It built successfully for us without any errors.
Please make sure that your GRC file's encoding is "UTF-8 with BOM".
Thanks. My grc file's encoding is "UTF-8 with BOM". But Often "illegal character" error occurs when there are many chinese characters in my grc file.
The error occurs in ***.grc.rc2.i file. How can I solve it ?
#303933
leilei wrote:
Tue Nov 19, 2019 6:01 pm
When you make a compilation error, put a space after the Chinese character.I compiled it in this way.
This problem occurs in Simple Chinese version of vs studio.
Thank you very much.
According to your method, this problem is solved.

Besides, I use Simple Chinese version of vs 2015.But I install the English Language pack ,the problem also occurs. I think the problem may be not caused by the vs language version ?