The Global Archicad Community

Stay informed. Get help. Share your knowledge.

Installation and download/setup issues; upgrading, operating system compatibility; getting started/training guides/tutorials. (Example: I cannot launch Archicad, please help!)

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

By McMurtrie
#304224
Anyone else have any issues with the installation of AC23 and Mac Mail? Immediately after installing, Mac's Mail program now crashes and will not open. After six hours on the phone with Apple today, they were able to get it running but without using my work email address as an account within Mac Mail.

I suspect it has something to do with the Software Key, which has my work email address as part of the link/communication.

I wasn't able to get AC going either, after maybe an hour with Graphisoft support. Fixing the mail took priority. Not too stoked to pay the ± $2K annual subscription only to have completely ruined my work day (and likely tomorrow's as well)....

Thoughts appreciated. I guess words of encouragement also...
User avatar
By Ghaleb Khadra
#304671
Hi,

I'm terribly sorry to see you are having an issue with this.
This is indeed very odd behavior and we have not encountered this before.

Nonetheless, I'm going to have my colleagues in the Technical Support team tackle this issue.

I wish you a great day, and I'm terribly sorry about the inconveniences caused by this.

I will post here again as soon as I have news about this.

Kind regards,
Ghaleb
#304675
Hello,

So after checking logs and processes, we are confident that ARCHICAD does not share any function or component with Mail app, so the chances of ARCHICAD crashing Mail app are rather slim.
The work email used for accessing licenses, is just for credentials (email and password) on GRAPHISOFT services. These credentials are (should be) different from the credentials used for accessing the email account in Mail app. ARCHICAD or any other GRAPHISOFT product does not request access to any email account.

I assume Apple support already suggested to run Mail app from another account on that machine. If the Mail app runs fine with a different user, then the issue is with user data on that user profile. On the off-chance they did not recommend that, I would kindly ask of you to test this and let me know of the results.

Kind regards,
Ghaleb & Technical Support Team
By McMurtrie
#305923
Thanks for responding, I didn't see your follow ups until just now. I'm technically pretty literate, I did work through trying to troubleshoot for a couple of days and got Apple involved as well. We got as far as we could and it was obvious to them that it was something with the Graphisoft software. It was bang-bang, as soon as I installed AC the mail crashed and no longer would be operable (nor with admin or newly created users). I gave up, I couldn't spend days on this and so I'm now using AirMail (which is OK but not preferred). I have backups of my mbox files but as I'm no longer using Mac's mail....

Honestly, Graphisoft still hasn't even gotten the License Manager Tool to work on my computer. I've got a workaround going that allows me to use the program while they try and figure out why I can't load the software key. I love the program but it's been a very time consuming experience trying to get things to work.

I think my system details should be in my signature now. macOS Catalina v10.15.2
User avatar
By Ralph Wessel
#305928
I agree with Ghaleb – I don't think there is any connection between ARCHICAD and macOS Mail. The structure of macOS also makes that very unlikely - you would have to be doing something really unprofessional to damage other applications on Installation.

It's more likely to be coincidence, but based on a pre-existing problem that only became apparent when you installed ARCHICAD. This can happen when (for example) the directory structure is corrupted, such that drive storage already used for files have been mistakenly marked as unused. If those blocks are written to during an installation, the existing files will be seriously damaged. It will appear as if the new installation caused the problem, when in fact the problem was already there. And if the file structure is corrupted, it will continue to cause damage the longer you work with it, i.e. it won't fix itself.

Did Apple support guide you through the process of rebooting in Recovery Mode and then running a full disk check with Disk Utility?
#306407
Hi,

Just a quick follow up: Are you still experiencing this issue?

macOS Catalina released a newer update (10.15.3) where they tackled a few issues and went more lenient with their restrictions and permissions. We found that to have solved many issues users experienced.
Additionally, the License Manager Tool was experiencing those issues you mentioned because WIBU-SYSTEMS AG had 32-bit based drivers which Catalina discontinued. Rest assured though, that they have released their 64-bit based drivers and we have integrated them within the License Manager Tool. Things should be running smoothly for a while now. :wink:

Kind regards,