The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Producing imagery with ARCHICAD or 3rd party products; Surfaces; Lighting; Cameras; Artlantis/Cinema 4D/Maxwell etc.

Moderators: Barry Kelly, Karl Ottenstein, LaszloNagy, ejrolon, gkmethy

User avatar
By Eric Batte
#306149
See attached. Any idea why flat slabs in ArchiCAD would be interpreted by Twinmotion like this?

File was exported by direct link from AC 22 to Twinmotion on Mac OS 10.15.2
Attachments
Fullscreen_1_24_20__4_16_PM.jpg
#306168
TM default export settings are creating this problem. You need to untick - optimise the geometry. See image attached.

I think this optimize setting is there for extremely large "complicate" AC 3D models, to not slow down in TM. That is only a guess.

Cheers Carsten
Attachments
TM optimze geometry.png
TM optimze geometry.png (32.07 KiB) Viewed 201 times
User avatar
By Eric Batte
#306201
Perfect! Thanks for that.

Interestingly, if I convert the slab to a morph it will remain "flat" even if the ™ export settings are not set to optimize.
User avatar
By mnguyen
#306440
Hi John,

Thank you for reporting the issue, and I'm very sorry about this experience!

I did a quick test with a curvy slab on ARCHICAD 22. Using Direct Link to export the model to Twinmotion, even with 'Optimize the geometry option' turned on, the slab did not show a dramatic wavy pattern on the surface as can be seen in this case (although at extreme zoom, it will show some segments at the curves).

Although we recommend to turn off this option to ensure better geometry export, this wavy pattern should not be there. I'm wondering if you could create a simple PLA file, that will show the issue when exporting to Twinmotion and forward it to us? That would be extremely helpful for further investigation! Thank you very much!

Best regards,
Minh

P/s: and thank you very much, Carsten, for your help in this case!
User avatar
By Carstenem
#306544
Hi Minh, thanks for investigating further.

If you export a Shell roof which is like a wave then the shell gets into TM not smooth enough, like the shell looks segmented. Again this only happens when you use the default setting "Optimize the geometry option"

So there seems to be a fundamental programming problem, where the optimize code is written.

Hope this helps.

Cheers Carsten