The Global ARCHICAD Community

Stay informed. Get help. Share your knowledge.

Everything related to BIMx and BIMx PRO: functionality, platforms, features, etc.

Moderators: ejrolon, Barry Kelly, Karl Ottenstein, LaszloNagy, gkmethy

#311177
Hi to everyone, I've got this problem with my clients:
When I create the model in Archicad I put every surface with the correct orientation, rotation, etc.
But when I export it the BimX show it as -usually- darker. Different colors.
I'm pretty sure that it's a problem of mine, that I need to setup the correct settings for Attenuance, Emission, etc.
I'm just curious if there is a way to do it quickly without the need to check everytime the BimX to display correctly.
Maybe a standard settings to start that don't change the JPEG image I use...

Any tips will be useful and much appreciated.
Thank you very much! :D
#311193
Hello f.scappiti,

Do you activate IG option into your 3D model view ?
IG bimx : https://helpcenter.graphisoft.com/knowledgebase/63253/

I invite you to open you bimx file with bimx lab on iOS to get the best render:
https://helpcenter.graphisoft.com/knowledgebase/85303/
#311197
Christophe Fortineau wrote:
Fri May 22, 2020 10:10 am
Hello f.scappiti,

Do you activate IG option into your 3D model view ?
IG bimx : https://helpcenter.graphisoft.com/knowledgebase/63253/

I invite you to open you bimx file with bimx lab on iOS to get the best render:
https://helpcenter.graphisoft.com/knowledgebase/85303/
Hi Christophe, thank you for your reply!
Yes I've activated GI on export, should I remove it?
That may be the issue for sure. Without GI the texture will display as in ArchiCad?

I'll give a try to BIMx lab, the only problem is that I've got no Ipad so just the client can try it, and their knowledge of tech it's absolutely nothing :lol:
#311216
Here is an example.
Archicad View:
Image

BimX windows PC View - No GI:
Image

BimX Smartphone View - with GI:
Image

Surface Settings:
Image

I've published the Windows Version without Global Illumination but seems that doesn't make any difference..
I've share the surface settings too, maybe it's there the problem.
Does BimX use Basic Engine or Open GL to generate the surfaces?
#311249
Christophe Fortineau wrote:Hello

Your BimX view is probably not darker but your Archicad view seems to be without shadow !
Isn't it ?
Yes it is without shadows! Thank you!
This is Archicad with Shadows enabled.
Image

So what should I do? Edit the texture image to a lighter color and leave settings to 0?
#311458
Hello f.scappiti,

I do not found your first picture realistic but I agree it's lighter.
You should try do modify you jpg texture into photoshop or other software to make it really lighter.
You can see these two pictures about the same bimx file into BIMX and BIMX LAB :
BIMX
Image
BIMX LAB
Image

BIMX LAB is lighter
To get the better way to see your model you should take the better device with BIMX LAB. :wink:
#311500
Hi All,

Thank you very much for your contribution to this topic!

I have done some research regarding this topic and found out that this is a known limitation of the current BIMx engine. On ARCHICAD, we have different ways of controlling how light and shadow is applied to a surface, whereas with BIMx, we do not have such freedom. In this particular case, the amount of light added to surfaces is based on their nodes' position.

Hopefully, with the new BIMx Lab's engine (that will arrive very soon), such issues will be eliminated. As demonstrated by Christophe, surfaces with BIMx Lab looks much more realistic and natural compared to the old engine on BIMx.

I hope this will address your concern about the issue! Have a nice day!

Best regards,
Minh